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Summary

In this tutorial, we will see where we can get the required data to generate maps using
SceneFromGIS.

We will need two types of data.

First, a digital elevation model, also known as a heightmap, which represent the altitude of
the terrain as a raster map. Those data are generally composed of multiple tiff files (tiles).
Second, topological layers, geospatial vector data which represent the different objects
we want to place in our maps. Topological layers can represent paths / roads, buildings /
walls, water surface / rivers or forest surface / hedge / tree. Those data are generally
composed of multiple Shapefile files (shp with their linked cpg, dbf, prj, gmd and shx files).
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Requirements

Software

Requirements

Usage

Link

QGIS Data preparation https://www.qgis.org/
Knowledge

GIS https://en.wikipedia.org/wiki/Geographic_information_system
CRS https://en.wikipedia.org/wiki/Spatial_reference_system

:/len.wikipedia.org/wiki/\VVector

Vector and raster http p g grap
https://en.wikipedia.org/wiki/Raster_graphics

raphics
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Data sources

In this tutorial we will use the example of data coming from IGN (Institut national de
l'information géographique et forestiére) but you can manage to use data from almost any
source, depending on the location you are interested in.

It's important to note that SceneFromGIS was developed using IGN data as source for tests,
meaning that the software is build to work fine with these data sources. Anyway, you will find
a way if you want to use other data source.

France

IGN : https://ign.fr/

Raster heightmap https://geoservices.ign.fr/rgealti
Vector layers https://geoservices.ign.fr/bdtopo
Spain

https://centrodedescargas.cnig.es/CentroDescargas/index.jsp
All the world

For vector layers, OpenStreetMap (OSM) is a good source of data.

OSM is a free, open geographic database updated and maintained by a community of
volunteers via open collaboration.

Pre-made Shapefile downloads and services generating custom Shapefile downloads exists.
bbbike.org is definitely a good starting point.

For more information, check the OSM wiki :

https://wiki.openstreetmap.org/wiki/Shapefiles#Obtaining_shapefiles_from_OSM_data

For digital elevation model, you can use OpenDEM, but the resolution is not very high
compared to state organization data previously cited. As far as we know, there is no better
open source alternative at this time. For more information : https://opendem.info/

Raster heightmap https://opendem.info/opendemeu_download_highres.html
Vector layers https://extract.bbbike.org/
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Prepare Data (QGIS)

Select the area

First, we need to select the center of the area we want to create a map from.

You can use Google Maps and right-click a point to get its exact location.

For example, the position 48.853159462022425, 2.349497366835291 correspond to
Notre-Dame de Paris.

You can use QGIS pluging “Lat Lon Tools” to view the exact position in QGIS user interface.

For this tutorial, we will focus on the area centered on 48.36473101843543,
7.429202290222781 which is located at Itterswiller, a commune in the Bas-Rhin
department in Alsace in north-eastern France.

Create project

Create a new project in QGIS, and set the projection system (CRS). The projection system
you choose should approximate the 1 m level, meaning that a difference of 1 in the
projection system, should correspond to a 1 m distance in the real world.

To change the CRS, there is a button located bottom right, looking like this :

& EpsG:4326

For example, the projected coordinate system for France is EPSG:2154 also named RFG93
or Lambert-93.

Each country / area has a different projection system to approximate the meter, in fact, as
the earth is not flat, we need to pick the good projection system linked to the area.

Import data

To import data, you can drag and drop your Shapefile and heightmap into the layers area
located in the lower left.
If everything goes as planned, you should have something like this.
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cReTo-BAD

| [ BATI INDIFFERENCIE

v [l SURFACE EAU

| — TRONCON_COURS_EAU

¥/ — ROUTE

¥/ ZONEVEGETATION
» v B RGEALTI_FXX 1026 6816 MNT_LAMB3 IGN69 2
» v B RGEALTI_FXX_1026_6817_MNT_LAMB3 IGN69 2
» v B RGEALTI_FXX 1026 6818 MNT_LAMB3 IGN69 2
» v B RGEALTI_FXX 1027 6816 MNT_LAMB3 IGN69 2
£ RGEALTI_FXX_1027_6817_MNT_LAMB93_IGN69 2
£ RGEALTI_FXX_1027_6818 MNT_LAMB3_IGN69 2
£ RGEALTI_FXX_1028 6816 MNT_LAMB3 IGN69 2
£ RGEALTI_FXX_1028 6817 MNT_LAMB93 IGN69 2
-

ESESESESES

RGEALTI_FXX_1028_6818 MNT_LAMB3_IGN69 ?

Aller 3 des coordonnées (=[]

Entrr Latiude, Longitds’ FERe

Example of a data importation using QGIS
red : path
yellow polygon : building
blue polygon : water
blue line : water path
green polygon : forest (alpha 20%)

Fusion heightmaps

If you have a heightmap as tiles, you can merge them using Raster > Misc > Fusion.

Select all the tiles and fuse them.
You can then export the result, don’t forget to force the CRS (SCR on the screenshot)
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2! Enregistrer la couche raster comme... *

Mode de sortie ® Donnée brute Image
Farmat GeoTIFF > Créer un VRT
MNom de fichier ] data\Ttterswiller \ALTT. tif

MNom de la couche

SCR SCR du Projet: EPSG:2154 - RGF93 w1 f Lambert-93 v ||

w Emprise (actuel : couche)

Maord |6318000,5000
Quest | 1025999,5000 Est |1028999,5000
Sud |5815000,5000
Calculate from Couche = | | LayoutMap ~ Signet  ~

Emprise de la couche sélectionnée | | Etendue du canevas de carte

w Résolution (actuelle : couche)

® Horizontal |1 Vertical |1 Résolution de la couche
Colonnes 3000 Lignes | 3000 Taille de |la couche
- Options de création
Profil | Défaut
Mom Valeur
v Ajouter les fichiers sauvegardés a la carte oK Annuler Aide

Force projection

You should always check that the projection of the file you export is the right one.
For raster, you can force a new projection using Raster > Projections > Assign Projection.
You can also export the layer and choose the projection in the CRS menu.

Change resolution

If you don’t have a 1 m resolution, you will need to alter it, as SceneFromGIS won’t make it
for you. The easiest way to do it is to export the layer you want and to force the resolution in
the menu.

SceneFromGIS 2023
All Rights Reserved



https://scenefromgis.14egaming.com/

(! Enregistrer la couche raster comme... >

Mode de sortie ® Donnée brute Image
Format GeoTIFF - Créer un VRT
Mom de fichier

MNom de la couche

SCR EPS5G:2154 - RGFS3 v1 / Lambert-33 v ||

w Emprise (actuel : couche)

Mord |6817136,1591
Quest |1027125,5173 Est |1028619,0511
Sud |6815641,9122
Calculate from Couche <= | |LayoutMap ~ Signet  ~

Emprise de |a couche sélectionnée | | Etendue du canevas de carte

w Résolution (actuelle : couche)

Horizontal |0,995559 Vertical |0,996165 Résolution de la couche
—
@) Colonnes I 1500 Lignes |1500 Taille de la couche
L J Options de création
Prafil | Défa
MNom Waleur
v Ajouter les fichiers sauvegardés a la carte K Annuler Aide

Cut heightmap

Itis very likely that the area of the heightmap you have doesn’t match the area you wanna
use as a map. As SceneFromGIS use the heightmap as background, this is the area which
will be considered as “the map”.

To cut a part in your heightmap, you can use Raster > Extraction > Clip Raster by Extent.
You can then choose your heightmap as a source and compute its extent.

In our example, the extent of the layer is the following :
1025999.5000,1028999.5000,6815000.5000,6818000.5000 [EPSG:2154]

As | want a 1500 m x 1500 m area, for example, | have to cut it.
Here is my exact steps :
- select the center of the area, right click, copy coordinate, CRS
> 1027882.3940248,6816356.6079377
- round values
> 1027882, 6816356
- +/- 750 (1500/2)
> 1027882 - 750
> 1027882 + 750

1027132
1028632
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> 6816356 - 750 6815606
> 6816356 + 750 6817106
> 1027132,1028632,6815606,6817106
- Clip Raster by Extent
- Export (right-click on the temporary layer in layers area)
> Don't forget to check the CRS !

e [~

» [I0A
» CIEN
P I fviden)

ouches 2®
« @ ® T o3 g

v [_] BATIINDIFFERENCIE

v [l SURFACE EAU

V| — TRONCON_COURS_EAU

| — ROUTE

v|  ZONE_VEGETATION
v ALTL1KS
oA
¥ RGEALTIFXX_1026 6816 MNT LAMB93 IGNG9 2
3 RGEALTIFXX 1026 6817 MNT LAMB3 IGN6D 2
I RGEALTIFXX_1026 6818 MNT LAMB93 IGN69 2
¥ RGEALTIFXX_1027 6816 MNT LAMB93 IGN69 2
B RGEALTIFXX_1027. 6817 MNT.LAMB93_IGN69 2
' RGEALTIFXX_1027 6818 MNT LAMB93 IGN69 2
" RGEALTIFXX_1028 6816 MNT LAMB93 IGN69 2
¥ RGEALTIFXX_1028 6817 MNT LAMB93 IGNG9 2
3 RGEALTIFXX 1028 6818 MNT LAMB3 IGN6D 2

Example of a raster fusion then cut using QGIS

Create vector layers

Your vector layers are probably not exactly extended as your heightmap.
We will create new layers from the ones you have imported.

Select area

First, select the layer you want to process in the layers list.
Second, select the entity selector tool in the toolbar.

Projet Editer Vue Couche Préférences Extensions Vecteur Raster Basededonnées Intemet Maillage Iraitement Aide
DEERRE Up2LHPPR I 4  ka tPNOZ P K-5% EHBI B -=-
LLAYAY 1R = = ® 2
bhELRE-€ X

Now drag a square around your heightmap to select all entities which are inside the
heightmap.

Now use edit > copy entities, to copy the selected entities.

Then select edit > paste as new vector layer, and save them in a new Shapefile.

SceneFromGIS can guess the type of layers you want to import using their name.
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The followings names are the best to use if you want to save time :

SceneFromGIS expected file names

Layer type Layer name
Heightmap * tif

Roads (line) path

Builds (polygon) building-poly
Builds (line) building-line
Vegetation (polygon) forest-poly
Vegetation (line) forest-line
Vegetation (point) forest-point
Water (polygon) water-poly
Water (line) water-line

You can then delete the unused vector layers.
You should now have a view looking like this.

Explorateur 88
DRYRO

Marque-pages
Y x

b [8) Aca
» [ €A\ (Windows)

Couches 88
¢vBeTE-BAFD

pat
V| forestpoly
vV ALTIIKS
¥ oan
I RGEALTI_FXX_1026 6816 MNT LAMBO3 IGN69 @
3 RGEALTI_FXX_1026_6817_MNT_LAMBO3_IGN69
I RGEALTIFXX_1026_6818 MNT LAMBO3 IGN69 @

W RGEALTIFXX_1027_6816_MNT_LAMB93 IGN69 @
B RGEALTI FXX_1027 6817 MNT_LAMB93 IGN69 2
W RGEALTIFXX_1027_6818_MNT_LAMB93 IGN69 2
I RGEALTI_FXX_1028_6816_MNT_LAMBE93_IGN69 2
W RGEALTIFXX_1028 6817_MNT_LAMB93 IGN69 2
W RGEALTIFXX_1028 6818 MNT_LAMB93 IGN69 @

Aller 3 des coordonnées @®
Enver Latitude, Longide’ R

483647310 1843543, 7.429202290222781

Example of a vector layer cut using QGIS

Edit layers

Some layers may be still larger than the area, which is not a big deal, but this may create

two problems.

First, it will slow down the further generation process.
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Second, if an element (e.g. polygon) has a part out of the bounds, it will not be included in
the generation process, which means a lot of lost time and lost data.

As an example, the original forest layer takes 30s to be generated but after this process, less
than 2s for a good result.

To edit the current layer, activate the edition mode :
NEAE 0@2LHPP A e tlOR KHE G- &E¥I = -=- &-
BQV.ZWED ®r-BW<D O =4 %= ® A

You can now select unwanted layers and delete them.

You can also use the vertex's editor to reduce polygon size.
NEEGEEY 02LHAPP " A Ba tOR K-0--5 ERIEH = - &-
#ev./eB® 4/ ArHza<so =4 %= ® -

Furthermore, you can now select unwanted vertices and delete them.

This could be a very tricky moment, as you don’t want to create holes or other aberrations in
the layer, as SceneFromGIS will not accept them.

A good idea is to advance step by step and to save intermediate results. If anything goes
wrong, you can go back to a safe setup.

Forest-poly
v v ALTLIKS
» @ A
¥ RGEALTLFXX.1026_6816_MNT_LAMBO3_ IGNG9 2
W RGEALTIFXX_1026 6817 MNT LAMB93 IGN69 2
' RGEALTI_FXX_1026_6818_MNT LAMB93 IGN69 2
¥ RGEALTI_FXX_1027_6816_MNT LAMB93 IGN69 2
B RGEALTLFXX 1027 6817 MNT_LAMBO3_ IGN69 2
3 RGEALTI_FXX_1027_6818_MNT LAMB93 IGN69 2
' RGEALT_FXX_1028 6816 MNT LAMB93 IGN69 2 A
' RGEALTI_FXX_1028 6817 MNT LAMB93 IGN69 2

¥ RGEALTLFXX_1028 6818 MNT_LAMB93 IGN69

Aller 3 des coordonnées. (1)

Entrer Lattude, Longitude EERNG

|48.3647310 1843543, 7.420202200200781

Example of a forest layer cleanup

Create alternative layers by attributes

An idea could be to create new layers from the existing ones, using attributes tables
information. For example, we can create a new path vector layer from the original path layer
selecting only the most important ones, checking the attribute maps.

We will not expand on this, as this is linked to the data source you will use, but this is
definitely a good trick to create multiple layers from a single one to have better final results.
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r @

b [ CA (Windows)
» oA

v OBy

» [ 1 tviden)

Couches. BE
e Tau B0
V' [_] building-poly
v [l water-poly
V| — water-line
V| path-important
V| — path
V|| forestpoly-clean —
forest-poly
b v B ATLIKS
b ¥ am
I RGEALTI_FXX_1026 6816 MNT LAMB93 IGN69 2
I RGEALTI_FXX_1026 6817 MNT LAMB93 IGN69 2
B RGEALTLFXX_ 1026 6878 MNT_LAMBO3 IGN69 P
I RGEALTI_FXX_1027_6816 MNT LAMB93 IGN69 2
I RGEALTI_FXX_1027_6817 MNT_LAMB93 IGN69 2
I RGEALTI_FXX_1027_6818 MNT LAMB93 IGN69 2
I RGEALTI_FXX_1028_6816_ MNT_LAMB93_IGN69 2
I RGEALTI_FXX_1028 6817 MNT LAMB93 IGN69 2
I RGEALTI_FXX_1028 6818 MNT LAMB93 IGN69 2

Aller  des coordonnées (=[]

Entrer Latiude, Longitude’ BEENG

|a8.35473101843843, 7.429202290222781] |

Example of a “major path” layer creation using attribute table
red : path
orange : important path
yellow polygon : building
blue polygon : water
blue line : water path
green polygon : forest

Random points in vector polygon

You can transform a polygon vector layer into a point vector layer using Vector > Search >
Random point in polygons.
This could be useful if you want to place trees more precisely during the preparation step.

Drape (vector line and points)

If there is no Z information for vector coordinate, a default 0 value for Z will be set by
SceneFromGlIS. Some 3D features will not work properly without Z information or with
original data (which may not be equal to heightmap).

You can use the Drape function from the toolbox to put the Z value from the heightmap to
any vector layer.
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Additional example using OSM and OpenDEM data

Import data

Explorateur

QRY*O
Marque-pages

» " Signets spatiaux

» [ Dossier du projet

v [&] Accueil

» [ CA (Windows)

v [I0n

[m)-N

> T fidden)

Couches

v @3eTE-FADL

V' [ buildings
V| — waterways
V| — roads
v natural

b V] B N2BOEA10

Aller 3 des coordonnées
Entrer Latitude, Longitude’ RN

148.36473101843543, 7.429202290222781]

Explorateur e®

(eI g )
Marque-pages

» 17 Signets spatiaux

» [ Dossier du projet

» [8] Accusil

+ [ CA (Windows)

r oA

» DB\

» TR tviden)

Couches a®

« il ® T = v
v [] building-poly

V| — water-ine
v/ — path
v forestpoly
=i ALTI 1k5 good res
Bande 1 (Gray)
390,056399

I 209,560898

» W ALTL 1k
» W ALTI 2154

Aller 3 des coordonnées. (=[]
Entrer Lattude, Longitude’ EIRY

48.36473101843543, 7.429202290222781

SceneFromGIS 2023
All Rights Reserved


https://scenefromgis.14egaming.com/

Explorateur

Levme
Marque-pages

» [ Signets spatiaux

» ¥ Dossier du projet

> [8] Accueil

» [ C\ Windows)

» T tviden)

Couches.

v W ¥ ALTI_1K5_good res
Bande 1 (Gray)
390,056699

209,550898
» W ALTL1KS
» W AT 2154

Aller 3 des coordonnées

Entrer Latitude, Longitude’

8%
AR
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Another example using IGN data

Example of a complete data preparation using QGIS
red : path
orange : path (important)
yellow polygon : building
yellow line : wall
blue polygon : water
blue line : water path
green polygon : forest
green line : hedge
green point : tree
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Troubleshooting

Polygon doesn’t show up

Your polygon (the ones not showing) are probably partially out of the heightmap, cut them.

Coast area

Coasts area can be tricky to handle, if you get problems, you should try to clip the Z value of
heightmap between [1, 10000].
| don't really know why there is this bug yet, but this seems to fix the problems.
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